Back to overview
Maintenance
Update the authentication system
Mar 19, 2026 at 4:55pm UTC
–
Mar 19, 2026 at 5:12pm UTC
Affected services
Authentication service
Resolved
Mar 19, 2026 at 5:12pm UTC
We updated the authentication system
Affected services