Back to overview
Resolved

Kubernetes load balancer is being slow

Apr 25, 2026 at 12:30pm UTC
Affected services
Load balancer

Resolved
Apr 26, 2026 at 11:34am UTC

The issue is resolved, and seems to be related to the registry and authentication downtime on 25th at 4am

Updated
Apr 26, 2026 at 1:00am UTC

The root cause seems to be a connection issue between a node and the load balancer. We are restarting the node. No service downtime expected.

Created
Apr 25, 2026 at 12:30pm UTC

For some services, the connection is being very slow or even dropped after being received by the LB. We are investigating.