Back to overview
Resolved

Update software

May 21, 2026 at 6:13pm UTC  –  May 21, 2026 at 6:31pm UTC
Affected services
AS205126 - par

Resolved
May 21, 2026 at 6:31pm UTC

Done

Updated
May 21, 2026 at 6:31pm UTC

Maintenance ended

Created
May 21, 2026 at 6:13pm UTC

We are updating a router