Back to overview
Resolved
Updating VPN service
Jul 14, 2026 at 8:20am UTC
–
Jul 14, 2026 at 8:23am UTC
Affected services
VPN service
Resolved
Jul 14, 2026 at 8:23am UTC
We maintenance went well and service up.
Affected services
Updated
Jul 14, 2026 at 8:23am UTC
Maintenance ended
Affected services
Created
Jul 14, 2026 at 8:20am UTC
We are updating the VPN service
Affected services